Back To Help

Which browser do I need to use to access the Portal?

May 15, 2015, 12:03 PM

The Portal will run under any of the newer browsers.  You can use Firefox, Chrome, Safari or Internet Explorer (version 8 and higher).  We do not recommend Internet Explorer versions 6 or 7.
Want the latest in aging research? Sign up for our email alerts.
Subscribe
© 2012 - 2019 McMaster University | 1280 Main Street West | Hamilton, Ontario L8S4L8 | +1 905-525-9140 | Terms Of Use